package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)https?:\/\/(?:www\.)?([-a-zA-Z0-9@:%._\+~#=]{2,256})(\.[a-z]{2,6}\b)*(\/[\/\d\w\.-]*)*(?:[\?])*(.+)*`)
var str = `http://wheaton.com/skin/media/main.js
https://wheaton.com/skin/media/main.js
http://www.wheaton.com/skin/media/main.js
https://www.wheaton.com/skin/media/main.js
http://wheaton.com/media/media/main.css
https://wheaton.com/media/media/main.css
http://www.wheaton.com/media/media/main.css
https://www.wheaton.com/media/media/main.css
http://wheaton.com/skin/media/main.png
https://wheaton.com/skin/media/main.jpg
http://www.wheaton.com/skin/media/main.jpeg
https://www.wheaton.com/skin/media/main.gif
http://go.wheaton.com/skin/media/main.png
https://go.wheaton.com/skin/media/main.jpg
http://go.wheaton.com/skin/media/main.jpeg
https://go.wheaton.com/skin/media/main.gif
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}