import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?:\\/\\/(?:www\\.)?([-a-zA-Z0-9@:%._\\+~#=]{2,256})(\\.[a-z]{2,6}\\b)*(\\/[\\/\\d\\w\\.-]*)*(?:[\\?])*(.+)*";
final String string = "http://wheaton.com/skin/media/main.js\n"
+ "https://wheaton.com/skin/media/main.js\n"
+ "http://www.wheaton.com/skin/media/main.js\n"
+ "https://www.wheaton.com/skin/media/main.js\n\n"
+ "http://wheaton.com/media/media/main.css\n"
+ "https://wheaton.com/media/media/main.css\n"
+ "http://www.wheaton.com/media/media/main.css\n"
+ "https://www.wheaton.com/media/media/main.css\n\n"
+ "http://wheaton.com/skin/media/main.png\n"
+ "https://wheaton.com/skin/media/main.jpg\n"
+ "http://www.wheaton.com/skin/media/main.jpeg\n"
+ "https://www.wheaton.com/skin/media/main.gif\n\n"
+ "http://go.wheaton.com/skin/media/main.png\n"
+ "https://go.wheaton.com/skin/media/main.jpg\n"
+ "http://go.wheaton.com/skin/media/main.jpeg\n"
+ "https://go.wheaton.com/skin/media/main.gif\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}