const regex = /https?:\/\/(?:www\.)?([-a-zA-Z0-9@:%._\+~#=]{2,256})(\.[a-z]{2,6}\b)*(\/[\/\d\w\.-]*)*(?:[\?])*(.+)*/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https?:\\\/\\\/(?:www\\.)?([-a-zA-Z0-9@:%._\\+~#=]{2,256})(\\.[a-z]{2,6}\\b)*(\\\/[\\\/\\d\\w\\.-]*)*(?:[\\?])*(.+)*', 'gi')
const str = `http://wheaton.com/skin/media/main.js
https://wheaton.com/skin/media/main.js
http://www.wheaton.com/skin/media/main.js
https://www.wheaton.com/skin/media/main.js
http://wheaton.com/media/media/main.css
https://wheaton.com/media/media/main.css
http://www.wheaton.com/media/media/main.css
https://www.wheaton.com/media/media/main.css
http://wheaton.com/skin/media/main.png
https://wheaton.com/skin/media/main.jpg
http://www.wheaton.com/skin/media/main.jpeg
https://www.wheaton.com/skin/media/main.gif
http://go.wheaton.com/skin/media/main.png
https://go.wheaton.com/skin/media/main.jpg
http://go.wheaton.com/skin/media/main.jpeg
https://go.wheaton.com/skin/media/main.gif
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}