using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"msg-type=""(?!(?:JOIN|INFO|TOPIC))[^""]+""";
string input = @"msg-type=""codePRIVMSGcode""
msg-type=""PRIVMSG""
msg-type=""PRIVMSGcode""
msg-type=""codePRIVMSG""
msg-type=""codeJOINcode""
msg-type=""JOIN""
msg-type=""JOINcode""
msg-type=""codeJOIN""
msg-type=""codeTOPICcode""
msg-type=""codeINFOcode""
msg-type=""PRIVMSG""
msg-type=""OTHER""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}