import re
regex = re.compile(r"msg-type=\"(?!(?:JOIN|INFO|TOPIC))[^\"]+\"", flags=re.MULTILINE)
test_str = ("msg-type=\"codePRIVMSGcode\"\n"
"msg-type=\"PRIVMSG\"\n"
"msg-type=\"PRIVMSGcode\"\n"
"msg-type=\"codePRIVMSG\"\n"
"msg-type=\"codeJOINcode\"\n"
"msg-type=\"JOIN\"\n"
"msg-type=\"JOINcode\"\n"
"msg-type=\"codeJOIN\"\n"
"msg-type=\"codeTOPICcode\"\n"
"msg-type=\"codeINFOcode\"\n"
"msg-type=\"PRIVMSG\"\n"
"msg-type=\"OTHER\"\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")