import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "msg-type=\"(?!(?:JOIN|INFO|TOPIC))[^\"]+\"";
final String string = "msg-type=\"codePRIVMSGcode\"\n"
+ "msg-type=\"PRIVMSG\"\n"
+ "msg-type=\"PRIVMSGcode\"\n"
+ "msg-type=\"codePRIVMSG\"\n"
+ "msg-type=\"codeJOINcode\"\n"
+ "msg-type=\"JOIN\"\n"
+ "msg-type=\"JOINcode\"\n"
+ "msg-type=\"codeJOIN\"\n"
+ "msg-type=\"codeTOPICcode\"\n"
+ "msg-type=\"codeINFOcode\"\n"
+ "msg-type=\"PRIVMSG\"\n"
+ "msg-type=\"OTHER\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}