import Foundation
let pattern = #"msg-type="(?!(?:JOIN|INFO|TOPIC))[^"]+""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
msg-type="codePRIVMSGcode"
msg-type="PRIVMSG"
msg-type="PRIVMSGcode"
msg-type="codePRIVMSG"
msg-type="codeJOINcode"
msg-type="JOIN"
msg-type="JOINcode"
msg-type="codeJOIN"
msg-type="codeTOPICcode"
msg-type="codeINFOcode"
msg-type="PRIVMSG"
msg-type="OTHER"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)