#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:(?:(?:([^:\/\/]+):)?\/\/)?(?:([\w\-.@]+)(?::(.*))?@)?([\w-.]+)(?::([0-9]+))?)?(?:(\/.*?\/?)(?:([\w-.]+))?)?(?:\?([^#]*))?(?:#(.*))?$"
Local $sString = "protocol://username@domain.com:p@ssw0rd@do-ma_in.com:80/path/path2/file.html?key1=value1&key2=value2#hash" & @CRLF & _
"protocol://username@domain.com@domain.com:80/path/file.html?key1=value1&key2=value2#hash" & @CRLF & _
"protocol://domain.com/path/file.html?key1=value1&key2=value2#hash" & @CRLF & _
"domain.com/path/file.html?key1=value1&key2=value2#hash" & @CRLF & _
"domain.com:80/path/file.html?key1=value1&key2=value2" & @CRLF & _
"#hash" & @CRLF & _
"?key1=value1&key2=value2#hash" & @CRLF & _
"username:password@domain.com:80#hash" & @CRLF & _
"/path/file.html" & @CRLF & _
"/file.html" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")