$re = '/^(?:(?:(?:([^:\/\/]+):)?\/\/)?(?:([\w\-.@]+)(?::(.*))?@)?([\w-.]+)(?::([0-9]+))?)?(?:(\/.*?\/?)(?:([\w-.]+))?)?(?:\?([^#]*))?(?:#(.*))?$/mi';
$str = 'protocol://username@domain.com:p@ssw0rd@do-ma_in.com:80/path/path2/file.html?key1=value1&key2=value2#hash
protocol://username@domain.com@domain.com:80/path/file.html?key1=value1&key2=value2#hash
protocol://domain.com/path/file.html?key1=value1&key2=value2#hash
domain.com/path/file.html?key1=value1&key2=value2#hash
domain.com:80/path/file.html?key1=value1&key2=value2
#hash
?key1=value1&key2=value2#hash
username:password@domain.com:80#hash
/path/file.html
/file.html
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);