using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:(?:([^:\/\/]+):)?\/\/)?(?:([\w\-.@]+)(?::(.*))?@)?([\w-.]+)(?::([0-9]+))?)?(?:(\/.*?\/?)(?:([\w-.]+))?)?(?:\?([^#]*))?(?:#(.*))?$";
string input = @"protocol://username@domain.com:p@ssw0rd@do-ma_in.com:80/path/path2/file.html?key1=value1&key2=value2#hash
protocol://username@domain.com@domain.com:80/path/file.html?key1=value1&key2=value2#hash
protocol://domain.com/path/file.html?key1=value1&key2=value2#hash
domain.com/path/file.html?key1=value1&key2=value2#hash
domain.com:80/path/file.html?key1=value1&key2=value2
#hash
?key1=value1&key2=value2#hash
username:password@domain.com:80#hash
/path/file.html
/file.html
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}