re = /^(?:(?:(?:([^:\/\/]+):)?\/\/)?(?:([\w\-.@]+)(?::(.*))?@)?([\w-.]+)(?::([0-9]+))?)?(?:(\/.*?\/?)(?:([\w-.]+))?)?(?:\?([^#]*))?(?:#(.*))?$/mi
str = 'protocol://username@domain.com:p@ssw0rd@do-ma_in.com:80/path/path2/file.html?key1=value1&key2=value2#hash
protocol://username@domain.com@domain.com:80/path/file.html?key1=value1&key2=value2#hash
protocol://domain.com/path/file.html?key1=value1&key2=value2#hash
domain.com/path/file.html?key1=value1&key2=value2#hash
domain.com:80/path/file.html?key1=value1&key2=value2
#hash
?key1=value1&key2=value2#hash
username:password@domain.com:80#hash
/path/file.html
/file.html
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end