// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(?:(?:(?:([^:\/\/]+):)?\/\/)?(?:([\w\-.@]+)(?::(.*))?@)?([\w-.]+)(?::([0-9]+))?)?(?:(\/.*?\/?)(?:([\w-.]+))?)?(?:\?([^#]*))?(?:#(.*))?$").unwrap();
let string = "protocol://username@domain.com:p@ssw0rd@do-ma_in.com:80/path/path2/file.html?key1=value1&key2=value2#hash
protocol://username@domain.com@domain.com:80/path/file.html?key1=value1&key2=value2#hash
protocol://domain.com/path/file.html?key1=value1&key2=value2#hash
domain.com/path/file.html?key1=value1&key2=value2#hash
domain.com:80/path/file.html?key1=value1&key2=value2
#hash
?key1=value1&key2=value2#hash
username:password@domain.com:80#hash
/path/file.html
/file.html
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}