#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(.*\n\n((^>+\s{1}.*$)+\n?)+)"
Local $sString = "and again" & @CRLF & _
"" & @CRLF & _
"2016-05-06 14:27 GMT+03:00 serg radzishevsky :" & @CRLF & _
"" & @CRLF & _
"> ok cool comment #2" & @CRLF & _
">" & @CRLF & _
"> 2016-05-06 14:24 GMT+03:00 Sergey Radzishevsky :" & @CRLF & _
">" & @CRLF & _
">> first comment" & @CRLF & _
">>" & @CRLF & _
">> *Lorem Ipsum* is simply dummy text of the printing and typesetting" & @CRLF & _
">> industry. Lorem Ipsum has been the industry's standard dummy text ever" & @CRLF & _
">> since the 1500s, when an unknown printer took a galley of type and" & @CRLF & _
">> scrambled it to make a type specimen book. It has survived not only five" & @CRLF & _
">> centuries, but also the leap into electronic typesetting, remaining" & @CRLF & _
">> essentially unchanged. It was popularised in the 1960s with the release of" & @CRLF & _
">> Letraset sheets containing Lorem Ipsum passages, and more recently with" & @CRLF & _
">> desktop publishing software like Aldus PageMaker including versions of" & @CRLF & _
">> Lorem Ipsum" & @CRLF & _
">>" & @CRLF & _
">> --" & @CRLF & _
">> *Sergey Radzishevsky*" & @CRLF & _
">> " & @CRLF & _
">> [image: Facebook page] [image:" & @CRLF & _
">> Twitter account] [image: Dribbble" & @CRLF & _
">> account] [image: Github repository]" & @CRLF & _
">> [image: Linkedin account]" & @CRLF & _
">> " & @CRLF & _
">>" & @CRLF & _
">> *Skype*: * radzserg*" & @CRLF & _
">>" & @CRLF & _
">>" & @CRLF & _
">" & @CRLF & _
">" & @CRLF & _
"> --" & @CRLF & _
"> Best Regards" & @CRLF & _
">" & @CRLF & _
"> Radzishevsky Sergey" & @CRLF & _
">" & @CRLF & _
"> *Skype: radzserg*" & @CRLF & _
">" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")