import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*\\n\\n((^>+\\s{1}.*$)+\\n?)+)";
final String string = "and again\n\n"
+ "2016-05-06 14:27 GMT+03:00 serg radzishevsky :\n\n"
+ "> ok cool comment #2\n"
+ ">\n"
+ "> 2016-05-06 14:24 GMT+03:00 Sergey Radzishevsky :\n"
+ ">\n"
+ ">> first comment\n"
+ ">>\n"
+ ">> *Lorem Ipsum* is simply dummy text of the printing and typesetting\n"
+ ">> industry. Lorem Ipsum has been the industry's standard dummy text ever\n"
+ ">> since the 1500s, when an unknown printer took a galley of type and\n"
+ ">> scrambled it to make a type specimen book. It has survived not only five\n"
+ ">> centuries, but also the leap into electronic typesetting, remaining\n"
+ ">> essentially unchanged. It was popularised in the 1960s with the release of\n"
+ ">> Letraset sheets containing Lorem Ipsum passages, and more recently with\n"
+ ">> desktop publishing software like Aldus PageMaker including versions of\n"
+ ">> Lorem Ipsum\n"
+ ">>\n"
+ ">> --\n"
+ ">> *Sergey Radzishevsky*\n"
+ ">> \n"
+ ">> [image: Facebook page] [image:\n"
+ ">> Twitter account] [image: Dribbble\n"
+ ">> account] [image: Github repository]\n"
+ ">> [image: Linkedin account]\n"
+ ">> \n"
+ ">>\n"
+ ">> *Skype*: * radzserg*\n"
+ ">>\n"
+ ">>\n"
+ ">\n"
+ ">\n"
+ "> --\n"
+ "> Best Regards\n"
+ ">\n"
+ "> Radzishevsky Sergey\n"
+ ">\n"
+ "> *Skype: radzserg*\n"
+ ">\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}