use strict;
my $str = 'and again
2016-05-06 14:27 GMT+03:00 serg radzishevsky :
> ok cool comment #2
>
> 2016-05-06 14:24 GMT+03:00 Sergey Radzishevsky :
>
>> first comment
>>
>> *Lorem Ipsum* is simply dummy text of the printing and typesetting
>> industry. Lorem Ipsum has been the industry\'s standard dummy text ever
>> since the 1500s, when an unknown printer took a galley of type and
>> scrambled it to make a type specimen book. It has survived not only five
>> centuries, but also the leap into electronic typesetting, remaining
>> essentially unchanged. It was popularised in the 1960s with the release of
>> Letraset sheets containing Lorem Ipsum passages, and more recently with
>> desktop publishing software like Aldus PageMaker including versions of
>> Lorem Ipsum
>>
>> --
>> *Sergey Radzishevsky*
>>
>> [image: Facebook page] [image:
>> Twitter account] [image: Dribbble
>> account] [image: Github repository]
>> [image: Linkedin account]
>>
>>
>> *Skype*: * radzserg*
>>
>>
>
>
> --
> Best Regards
>
> Radzishevsky Sergey
>
> *Skype: radzserg*
>
';
my $regex = qr/(.*\n\n((^>+\s{1}.*$)+\n?)+)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}