import Foundation
let pattern = #"(.*\n\n((^>+\s{1}.*$)+\n?)+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
and again
2016-05-06 14:27 GMT+03:00 serg radzishevsky :
> ok cool comment #2
>
> 2016-05-06 14:24 GMT+03:00 Sergey Radzishevsky :
>
>> first comment
>>
>> *Lorem Ipsum* is simply dummy text of the printing and typesetting
>> industry. Lorem Ipsum has been the industry's standard dummy text ever
>> since the 1500s, when an unknown printer took a galley of type and
>> scrambled it to make a type specimen book. It has survived not only five
>> centuries, but also the leap into electronic typesetting, remaining
>> essentially unchanged. It was popularised in the 1960s with the release of
>> Letraset sheets containing Lorem Ipsum passages, and more recently with
>> desktop publishing software like Aldus PageMaker including versions of
>> Lorem Ipsum
>>
>> --
>> *Sergey Radzishevsky*
>>
>> [image: Facebook page] [image:
>> Twitter account] [image: Dribbble
>> account] [image: Github repository]
>> [image: Linkedin account]
>>
>>
>> *Skype*: * radzserg*
>>
>>
>
>
> --
> Best Regards
>
> Radzishevsky Sergey
>
> *Skype: radzserg*
>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)