# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(sort=.*?&)//g;t' <<< "category_id=249&sort=name&category_filter=15&"