import Foundation
let pattern = #"(sort=.*?&)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"category_id=249&sort=name&category_filter=15&"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)