#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(sort=.*?&)"
Local $sString = "category_id=249&sort=name&category_filter=15&"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)