use strict;
my $str = 'category_id=249&sort=name&category_filter=15&';
my $regex = qr/(sort=.*?&)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";