#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([1823742]).*(?!\1)[1823742]"
Local $sString = "123" & @CRLF & _
"159" & @CRLF & _
"147" & @CRLF & _
"258" & @CRLF & _
"357" & @CRLF & _
"369" & @CRLF & _
"456" & @CRLF & _
"789" & @CRLF & _
"" & @CRLF & _
"NOTE:" & @CRLF & _
"15555551" & @CRLF & _
"151" & @CRLF & _
"2562"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")