import re
regex = re.compile(r"([1823742]).*(?!\1)[1823742]", flags=re.MULTILINE)
test_str = ("123\n"
"159\n"
"147\n"
"258\n"
"357\n"
"369\n"
"456\n"
"789\n\n"
"NOTE:\n"
"15555551\n"
"151\n"
"2562")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")