re = /([1823742]).*(?!\1)[1823742]/m
str = '123
159
147
258
357
369
456
789
NOTE:
15555551
151
2562'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end