$re = '/([1823742]).*(?!\1)[1823742]/m';
$str = '123
159
147
258
357
369
456
789
NOTE:
15555551
151
2562';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);