const regex = /([1823742]).*(?!\1)[1823742]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([1823742]).*(?!\\1)[1823742]', 'gm')
const str = `123
159
147
258
357
369
456
789
NOTE:
15555551
151
2562`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}