using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:\d+\.?){4})(?:.+?""){4}\s+("".*?"")";
string input = @"66.249.74.18 - - [21/Apr/2013:05:55:33 +0000] 200 ""GET /1.jpg HTTP/1.1"" 7691 ""-"" ""Googlebot-Image/1.0"" ""-""
220.181.108.96 - - [21/Apr/2013:05:55:33 +0000] 200 ""GET /1.html HTTP/1.1"" 17722 ""-"" ""Mozilla/5.0 (compatible; Baiduspider/2.0; +http://www.baidu.com/search/spider.html)"" ""-""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}