import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:\\d+\\.?){4})(?:.+?\"){4}\\s+(\".*?\")";
final String string = "66.249.74.18 - - [21/Apr/2013:05:55:33 +0000] 200 \"GET /1.jpg HTTP/1.1\" 7691 \"-\" \"Googlebot-Image/1.0\" \"-\"\n"
+ "220.181.108.96 - - [21/Apr/2013:05:55:33 +0000] 200 \"GET /1.html HTTP/1.1\" 17722 \"-\" \"Mozilla/5.0 (compatible; Baiduspider/2.0; +http://www.baidu.com/search/spider.html)\" \"-\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}