import re
regex = re.compile(r"^((?:\d+\.?){4})(?:.+?\"){4}\s+(\".*?\")", flags=re.MULTILINE)
test_str = ("66.249.74.18 - - [21/Apr/2013:05:55:33 +0000] 200 \"GET /1.jpg HTTP/1.1\" 7691 \"-\" \"Googlebot-Image/1.0\" \"-\"\n"
"220.181.108.96 - - [21/Apr/2013:05:55:33 +0000] 200 \"GET /1.html HTTP/1.1\" 17722 \"-\" \"Mozilla/5.0 (compatible; Baiduspider/2.0; +http://www.baidu.com/search/spider.html)\" \"-\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")