// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^((?:\d+\.?){4})(?:.+?"){4}\s+(".*?")"#).unwrap();
let string = "66.249.74.18 - - [21/Apr/2013:05:55:33 +0000] 200 \"GET /1.jpg HTTP/1.1\" 7691 \"-\" \"Googlebot-Image/1.0\" \"-\"
220.181.108.96 - - [21/Apr/2013:05:55:33 +0000] 200 \"GET /1.html HTTP/1.1\" 17722 \"-\" \"Mozilla/5.0 (compatible; Baiduspider/2.0; +http://www.baidu.com/search/spider.html)\" \"-\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}