# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.{3})(.{3})(.{4})$/$1.$2.$3/;t' <<< "7882347812"