use strict;
my $str = '7882347812';
my $regex = qr/^(.{3})(.{3})(.{4})$/p;
my $subst = '$1.$2.$3';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";