const regex = /^(.{3})(.{3})(.{4})$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.{3})(.{3})(.{4})$', '')
const str = `7882347812`;
const subst = `$1.$2.$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);