// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(.{3})(.{3})(.{4})$").unwrap();
let string = "7882347812";
let substitution = "$1.$2.$3";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}