#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^~"
Local $sString = "dgdfgdfg~sdfsdf.pdf"
Local $sSubst = "sdfsdf.pdf"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)