use strict;
my $str = 'dgdfgdfg~sdfsdf.pdf';
my $regex = qr/^~/mp;
my $subst = 'sdfsdf.pdf';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";