using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Edit).+?(?=,)";
string substitution = @"";
string input = @"EditMumbai, Maharashtra, IndiaCurrent City";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}