$re = '/(?<=Edit).+?(?=,)/';
$str = 'EditMumbai, Maharashtra, IndiaCurrent City';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;