import re
regex = re.compile(r"(?<=Edit).+?(?=,)")
test_str = "EditMumbai, Maharashtra, IndiaCurrent City"
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)