const regex = /(?<=Edit).+?(?=,)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Edit).+?(?=,)', '')
const str = `EditMumbai, Maharashtra, IndiaCurrent City`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);