use strict;
my $str = 'EditMumbai, Maharashtra, IndiaCurrent City';
my $regex = qr/(?<=Edit).+?(?=,)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";