using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:int|float|String|char|double|long)\b\s+([^=;]+)";
string input = @" int a = 100;
float b = 110;
String c = ""Hello World"";
double a, b, c = 0;
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}