$re = '/\b(?:int|float|String|char|double|long)\b\s+([^=;]+)/m';
$str = ' int a = 100;
float b = 110;
String c = "Hello World";
double a, b, c = 0;
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);