package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:int|float|String|char|double|long)\b\s+([^=;]+)`)
var str = ` int a = 100;
float b = 110;
String c = "Hello World";
double a, b, c = 0;
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}