re = /\b(?:int|float|String|char|double|long)\b\s+([^=;]+)/m
str = ' int a = 100;
float b = 110;
String c = "Hello World";
double a, b, c = 0;
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end