// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(?:int|float|String|char|double|long)\b\s+([^=;]+)").unwrap();
let string = " int a = 100;
float b = 110;
String c = \"Hello World\";
double a, b, c = 0;
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}