using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^role\s*[:]\s*(?!rolename)[\w]+)((,(?!rolename)[\w]+)*)$";
string input = @"role: rolenam1,common,app,web,rolenam2,db,rolenam3";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}