re = /(^role\s*[:]\s*(?!rolename)[\w]+)((,(?!rolename)[\w]+)*)$/
str = 'role: rolenam1,common,app,web,rolenam2,db,rolenam3'
# Print the match result
str.match(re) do |match|
puts match.to_s
end