const regex = new RegExp('(^role\\s*[:]\\s*(?!rolename)[\\w]+)((,(?!rolename)[\\w]+)*)$', '')
const str = `role: rolenam1,common,app,web,rolenam2,db,rolenam3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}