$re = '/(^role\s*[:]\s*(?!rolename)[\w]+)((,(?!rolename)[\w]+)*)$/';
$str = 'role: rolenam1,common,app,web,rolenam2,db,rolenam3';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);