#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:[^(|)]*+(\((?:[^()]++|(?1))\))?+)*+\K\|"
Local $sString = "example|example (example(example))|example|example|example(example|example|example(example|example))|example"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)